Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
32 user(s) are online (8 user(s) are browsing Forums)

Members: 0
Guests: 32

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 2 3 4 (5)


Re: Some OS4.1 bugs
Not too shy to talk
Joined:
2006/11/27 22:28
From Germany
Posts: 264
@TSK

Quote:

TSK wrote:
@MichaelMerkel

Can you confirm what I found ?


well, i burnt an os4.1upd1 install cd and bootet from it completely as a start. no grim reaper crash from here.
then i warm bootet into my normal hd.
also no gr crash.

so i can add:
using kickstart setup from 4.1upd1 +my up2 hd -> no crash
using kickstart setup from 4.1upd2 +my up2 hd -> crash

but i had so many different situations now... some crash some don't and the next moment... well...



regards...

_________________
Michael Merkel
(Michael.Merkel@gmx.net Home)
Member of Amiga-Freunde Pfalz, OS4 Welt
   Report Go to top

Re: Some OS4.1 bugs
Quite a regular
Joined:
2007/2/23 13:49
From Finland, the land of Santa, sauna, sisu and salmiakki
Posts: 982
@MichaelMerkel

Did you try to delete locale.prefs and check if you still get crash ?

_________________
Extremely happy X1000 user. Be authentic.
"Anyone can build a fast CPU. The trick is to build a fast system." - Seymour Cray
AmigaOne X1000
   Report Go to top

Re: Some OS4.1 bugs
Not too shy to talk
Joined:
2006/11/27 22:28
From Germany
Posts: 264
@TSK

Quote:

TSK wrote:
@MichaelMerkel

Did you try to delete locale.prefs and check if you still get crash ?


just tried it by deleteing the locale.prefs. reset.
test program - grim reaper - crash.

yes - i still get the crash.

regards...

_________________
Michael Merkel
(Michael.Merkel@gmx.net Home)
Member of Amiga-Freunde Pfalz, OS4 Welt
   Report Go to top

Re: Some OS4.1 bugs
Home away from home
Joined:
2007/5/19 13:23
Posts: 2815
Just a follow-up to my post #5, which was about OS4's poor network set-up. So not a bug as such, but it's so bad it really should be treated as one.

Hypex & others were moaning about Roadshow on AmigaWorld, to which I replied:

Olaf's Roadshow is basically fine by modern standards... The problem is that OS4 doesn't come with useful default settings (hardly Olaf's fault). Why the hell does one need to configure DHCP manually? This should be *standard*, just like on Windows, Linux, etc - which are just plug'n'go for broadband routers.

I certainly agree the OS4 team badly need to take another look at networking. The sad thing is that the solutions are so *trivial*. I believe their (misguided) thinking is something like "we cannot guarantee the correct settings, so we leave it up to the user to configure it." Bzzzt, sorry, that just isn't good enough, since you can guarantee over 50% of users will configure it wrong, where-as default settings are over 90% likely to work.

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1 on my A1-X1000 & Sam440
Don't forget the official support forum for OS4!
   Report Go to top

Re: Some OS4.1 bugs
Amigans Defender
Joined:
2006/11/26 23:16
Posts: 980
@ChrisH
Quote:
...over 50% of users will configure it wrong, where-as default settings are over 90% likely to work.

One should also note that 84% of statistics are made up on the spot and have no meaning.

_________________
Be authentic. Get AmigaOS.
Amiga Users of Calgary (AMUC)
   Report Go to top

Re: Some OS4.1 bugs
Just popping in
Joined:
2006/12/4 1:03
From Sweden
Posts: 124
@ssolie

.. 16% of all statistics are not made up then.. How do we tell the difference?

_________________
Best Regards,

Harry

[SOLD] µA1-C, 512MB, Antec Aria
   Report Go to top

Re: Some OS4.1 bugs
Just popping in
Joined:
2006/12/4 1:03
From Sweden
Posts: 124
@ssolie

Btw ChrisH, although a bit harsh in his post, is right.
DHCP should be default, also run when starting network.
Slowing down startup is worse than some programs requiring
network complaining the first 10-20secs after boot is finished
IMHO.

_________________
Best Regards,

Harry

[SOLD] µA1-C, 512MB, Antec Aria
   Report Go to top

Re: Some OS4.1 bugs
Just popping in
Joined:
2007/4/15 0:08
From Norway
Posts: 61
@ChrisH

Quote:
Olaf's Roadshow is basically fine by modern standards...

Hah, if by modern you mean 15 years ago, perhaps.

_________________
-- kolla
   Report Go to top

Re: Some OS4.1 bugs
Quite a regular
Joined:
2009/4/28 3:57
From Adelaide, Australia
Posts: 704
Why didn't I ever report this before? OK, stick in the Sam440 4.1 Update 1 CD. Wait for it to be recognized.

The CD icon is not shown. There is nothing you can click on until you do an icon cleanup (ramiga+. a couple of times will do it).

Same thing if you just mount the iso with DiskImageGUI.

I do scale my icons.

   Report Go to top

Re: Some OS4.1 bugs
Home away from home
Joined:
2007/5/19 13:23
Posts: 2815
@ssolie Quote:
One should also note that 84% of statistics are made up on the spot and have no meaning.

What I quoted were NOT statistics, but numerical estimates for what I felt the situation is, based upon actual experience with real users & routers (plus reports on AW.net & Amigans.net).

I could have said "the majority of users will configure it wrong", but it's easier (and clearer) to just say "over 50%". And I could have said "DHCP will work in most situations" but I felt it was clearer to say "over 90%". And using numbers allows one to compare to the two cases (as well as argue about them), and clearly see what the best choice is.

Also, DHCP should work in 99% of situations (it will do for Windows/etc) but Roadshow seems to have problems with a few routers not doing DHCP properly, so I said "over 90%" instead of 99%.

P.S. 97.6% of fans of "The Fall and Rise of Reginald Perrin" over-use that infamous statistics joke...

@samwel Quote:
Btw ChrisH, although a bit harsh in his post, is right.
DHCP should be default, also run when starting network.

Thanks. For new users, networking is currently the single worst thing about OS4, so I think it's reasonable to be a bit harsh. Especially since the technically-knowledgable OS4 team may not see the problem from a non-technical user perspective.

@kolla Quote:
Hah, if by modern you mean 15 years ago, perhaps.

OK then, let's see YOU configure Windows XP to have (say) a static IP address &use a static DNS server.... You will find it as (if not more) complex than using Roadshow on OS4.

OS4's problem is NOT Roadshow (it's TCP/IP stack) but rather the fact that it doesn't come pre-configured to use DHCP, where-as Windows/etc do. Quite barmy!


Edited by ChrisH on 2010/8/25 9:13:24
Edited by ChrisH on 2010/8/25 9:14:12
Edited by ChrisH on 2010/8/25 9:25:09
Edited by ChrisH on 2010/8/25 9:26:54
Edited by ChrisH on 2010/8/25 10:02:41
_________________
Author of the PortablE programming language.
I love using Amiga OS4.1 on my A1-X1000 & Sam440
Don't forget the official support forum for OS4!
   Report Go to top

Re: Some OS4.1 bugs
Just popping in
Joined:
2010/6/1 11:46
From United Kingdom
Posts: 229
Noticed a 'bug' today in OS4.1 update 2...

When emptying trashcan, requester asks if you want to delete '1 drawer (and contents)?'. But of course Trashcan 'drawer' is not deleted only the files inside are deleted with this operation.

   Report Go to top

Re: Some OS4.1 bugs
Amigans Defender
Joined:
2006/11/26 23:16
Posts: 980
@ChrisH
Quote:
P.S. 97.6% of fans of "The Fall and Rise of Reginald Perrin" over-use that infamous statistics joke...

There are lies, damned lies and statistics.

_________________
Be authentic. Get AmigaOS.
Amiga Users of Calgary (AMUC)
   Report Go to top

Re: Some OS4.1 bugs
Home away from home
Joined:
2007/5/19 13:23
Posts: 2815
@ssolie Quote:
There are lies, damned lies and statistics

Yup, but what I posted were not statistics (in the normal sense of objective percentages derived from a survey or study), but rather numerical values (percentages) which closely matched what I thought was the case (based upon my experience).

Using numbers to state something is less open to misinterpretation (and easier to argue about) than if I used vague words/phrases. Of course my numbers have large error bars (uncertainty), but still much more useful than nothing. For any further clarification, please see my previous post....

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1 on my A1-X1000 & Sam440
Don't forget the official support forum for OS4!
   Report Go to top


« 1 2 3 4 (5)



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2014 The XOOPS Project