Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
24 user(s) are online (14 user(s) are browsing Forums)

Members: 0
Guests: 24

more...
Support us!
Recent OS4 Files
OS4Depot.net





Qt native text rendering bug
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
Spot the difference:

Resized Image
Resized Image

The lower one is with native fonts enabled.

Also, I'm seeing a crash when Qt tries to open a native file requester:
http://crashlog.os4depot.net/cl355

qMetro binary for testing


   Report Go to top

Re: Qt native text rendering bug
Home away from home
Joined:
2007/5/19 13:23
Posts: 2815
I am unable to view any embedded photos on Amigans.net, like those above. Clicking on their thumbnails in MUI-OWB just leads to a blank page.

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1 on my A1-X1000 & Sam440
Don't forget the official support forum for OS4!
   Report Go to top

Re: Qt native text rendering bug
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
@ChrisH

Well, that's an MUI-OWB bug not a Qt bug

Here are the direct links:
http://homepage.ntlworld.com/cdyoung/tmp/qmetro1.jpg
http://homepage.ntlworld.com/cdyoung/tmp/qmetro1_nf.jpg

   Report Go to top

Re: Qt native text rendering bug
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 2745
Then you should open a new ticket also for MUI OWB

http://bugs.os4depot.net/?function=viewissues&softwareid=15

   Report Go to top

Re: Qt native text rendering bug
Quite a regular
Joined:
2009/10/7 0:11
Posts: 986
@Chris

Hmmm... Is the top one using OpenGL? Because that is very strange, given that some of the letters (like 'O's) are filled in. The 'filled in' letters are a symptom that signals, that the native renderer has been used to render a QPainterPath version of the text.

The bottom one sure looks strange too. But basically this is to be expected, since the (sort of) complex native renderer class has been built up from scratch and thus not everything works as expected. Especially the text alignment is just off most of the time, since Amiga fonts don't seem to interpret the font dimensions in the same way as freetype.

Some useful information you could provide me with:

* Which font is used to draw the 'filled rectangular' parts?
* which font engine are you using (ie. 'native' or freetype) in the two examples?
* Which string codec are you using?
* What does the rendering function (ie. YourClass::paintEvent() most likely) look like?

EDIT: Ok, I misread, I thought this was a question of native vs. opengl rendering and not fonts. Well, as I said, the top one shows signs of being rendered with the QPainterPath class (probably because of zooming) and the bottom one, well, I think there must be some issue, that prevents the rendering of the rectangular areas, probably related to string codec used. And the reason the text is misaligned is because I haven't figured out how to do "correct" alignment with Amiga fonts.

Do you have the source up for grabs somewhere?


Edited by alfkil on 2013/4/1 0:59:23
   Report Go to top

Re: Qt native text rendering bug
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862

   Report Go to top





[Advanced Search]


Powered by XOOPS 2.0 © 2001-2014 The XOOPS Project