Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
16 user(s) are online (7 user(s) are browsing Forums)

Members: 0
Guests: 16

more...
Support us!
Recent OS4 Files
OS4Depot.net



(1) 2 »


MUIOWB fonts !!FIXED!!
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 335
At Amiga.org and motors.ebay a lot of the pages are displayed with a Greek font. Reading English words in a Greek font is really slow going!

Amiga.org's home page is OK. But any subsequent pages display many (but not all) parts of the page in Greek.

The prefs for MUIOWB no longer include Cyberbit. I thought maybe that was the problem.

A while back I deleted and totally reinstalled MUIOWB after deleting and re-running the font cache first. But I still have the problem.

Now that I finally have OpenURL working correctly between Simplemail and OWb, I'd like to get rid of this last problem.

Any ideas to solve this?

Thanks.

Paul


Edited by Paul on 2012/11/8 3:04:44
   Report Go to top

Re: MUIOWB fonts
Home away from home
Joined:
2007/5/19 13:23
Posts: 2815
Since you still have the same problem after deleting & reinstalling MUI-OWB, the problem 'must' be in some system setting, but I don't know what...

   Report Go to top

Re: MUIOWB fonts
Quite a regular
Joined:
2006/12/1 18:01
From Copenhagen, Denmark
Posts: 902
Make sure your Text Encoding on the Fonts tab of the MUIOWB preferences is set to ISO-8859-1.

If that's not the problem, I'd try going to the system's Locale prefs and clicking on the Clear languages button, then Save (or Use). If that makes a difference, go back in and select your primary language first, then if you want, other languages afterwards.

You might have your system charset (which is determined by the first preferred language) messed up.

Best regards,

Niels

   Report Go to top

Re: MUIOWB fonts
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 335
@Niels,

Thanks for the suggestions.

My text encoding WAS wrong. It was set to ISO-8859-2. But chaning it to ISO-8859-1 didn't help the problem.

Locale settings were correctly set only to english/USA.

I've re-run Fixfonts and checked over what showed up in Typemanager. All seems to be appropriate. And after re-running fix-fonts, MUIOWB re-ran its own font cache. newegg.com is a prime example of this Greek font problem.

Paul

   Report Go to top

Re: MUIOWB fonts
Quite a regular
Joined:
2008/11/19 22:44
From Colossal Cave, Valaii
Posts: 529
Greek is ISO-8859-7. I checked that newegg.com site, but I have not any problems, it's all in english.

   Report Go to top

Re: MUIOWB fonts
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
On a related note, can somebody remind which file I need to delete to stop MUI-OWB scanning fonts every time it starts up?

   Report Go to top

Re: MUIOWB fonts
Quite a regular
Joined:
2006/12/1 18:01
From Copenhagen, Denmark
Posts: 902
Quote:
Chris wrote:
On a related note, can somebody remind which file I need to delete to stop MUI-OWB scanning fonts every time it starts up?
It's the one with the long hex name ending in -ppc-amigaos in the path muiowb/Conf/font/.

Best regards,

Niels

   Report Go to top

Re: MUIOWB fonts
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
Thanks! Might have found it myself had I been looking in MUI-OWB rather than RA-OWB's drawer....

   Report Go to top

Re: MUIOWB fonts
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 335
I've checked the things Niels mentioned. And Phantom has checked the newegg.com page and had no errors on his installation of MUIOWB.

What fonts are people using in their MUIOWB setups? Mine were mainly DejaVu typefaces. I also tried using Bitstream Serif and Sans typefaces, but nothing changed.

Paul

   Report Go to top

Re: MUIOWB fonts
Home away from home
Joined:
2007/5/19 13:23
Posts: 2815
@Paul
I've got Microsoft's "core web" fonts installed, so I am using "Times New Roman" for the Standard Font Family & Serif Font, "Courier New" for Monospaced Font, and "Arial" for Sans Serif Font. I have Text Encoding set to ISO-8859-1 (the default).

   Report Go to top

Re: MUIOWB fonts
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 335
Chris,

Thanks. I'll give those fonts a try when I get home again.

Paul

   Report Go to top

Re: MUIOWB fonts
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 335
Chris,

I already had the core fonts installed so it was an easy switch in the OWB prefs.

Maddeningly, it didn't change anything. The product descriptions on newegg.com still appear in a Greek font.

I sure wish I or someone else could figure out where this is going wrong!

Paul

   Report Go to top

Re: MUIOWB fonts
Quite a regular
Joined:
2006/12/1 18:01
From Copenhagen, Denmark
Posts: 902
That's really weird, Paul. It doesn't happen for me, is all I can say.

Does it happen for you on any other pages?

Best regards,

Niels

   Report Go to top

Re: MUIOWB fonts
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 335
Niels,

Yes, it does show on some --but not all-- other pages.
The home page of Amiga.org displays some items in Greek, and "sub"-pages there show even more in Greek.

THe index page at motors.ebay.com is OK, but "sub" pages start showing some items in Greek.

RA-OWB, Netsurf and Timberwolf do not have this problem at all.

Paul

Resized Image


Resized Image

Resized Image

Resized Image


Edited by Paul on 2012/10/29 2:20:46
   Report Go to top

Re: MUIOWB fonts
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
@Paul

1. Delete the file mentioned in post #7
2. Run FixFonts for good measure
3. Open OWB and try again

   Report Go to top

Re: MUIOWB fonts
Quite a regular
Joined:
2008/11/19 22:44
From Colossal Cave, Valaii
Posts: 529
Did you check your locale prefs? I don't know if they play a serious part in MUI-OWB though.

   Report Go to top

Re: MUIOWB fonts
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 335
Chris,

Quote:
1. Delete the file mentioned in post #7
2. Run FixFonts for good measure
3. Open OWB and try again


I had done this before several times, but couldn't recall if I did it in that order. So I did it one more time last night.

Still get the Greek font at the same sites.

Paul

quick edit: the Risc OS Pi link provided by mechanic in another thread is ENTIRELY in Greek font.

   Report Go to top

Re: MUIOWB fonts
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 335
Quote:

Phantom wrote:
Did you check your locale prefs? I don't know if they play a serious part in MUI-OWB though.


Yes. All I have is "english" "USA" and eastern time zone. No other languages listed.

Paul

   Report Go to top

Re: MUIOWB fonts
Quite a regular
Joined:
2006/12/1 18:01
From Copenhagen, Denmark
Posts: 902
What does a "GetEnv Charset" in a Shell say?

Best regards,

Niels

   Report Go to top

Re: MUIOWB fonts
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 335
Quote:

nbache wrote:
What does a "GetEnv Charset" in a Shell say?


Niels,

ISO-8859-1is all that comes back in the shell.

Paul

   Report Go to top


(1) 2 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2014 The XOOPS Project