Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
15 user(s) are online (8 user(s) are browsing Forums)

Members: 0
Guests: 15

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 2 3 (4) 5 6 7 ... 40 »


Re: Beta testing
Quite a regular
Joined:
2009/10/7 0:11
Posts: 986
@Hans

From wikipedia I can read, that the gold linker is included in binutils 2.19. The adtools trunk apparently only includes binutils 2.18. So if I have to use it, I will need to build it first, I guess.

   Report Go to top

Re: Beta testing
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 2745
@Alfkil

Quote:
They work, you just have to start them from a console with an url as argument.


Mmm I see, however they shouldn't crash i think (?)

Quote:
Did you manage to download anything with it? If you did, that is remarkable, because I haven't been able to. I think it needs to update some protocols or whatever..


No in this case i only tested if the demo started and nothing else, i didn't test the download functionality on this one (no time with all that demos!)

Aniway right now i'm trying to download somethings but the file still at 0% (10 minutes) so most probably you are right ..

Don't know if it's the same for you but at startup i have also this output:

Quote:
The usage of QHttp is not recommended anymore, please use QNetworkAccessManager.


   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2007/1/26 21:48
From New Zealand
Posts: 1617
Quote:

alfkil wrote:
@Hans

From wikipedia I can read, that the gold linker is included in binutils 2.19. The adtools trunk apparently only includes binutils 2.18. So if I have to use it, I will need to build it first, I guess.


That's a pity.

@all
Is there any other developer who wants to take a shot at updating adtools?

Hans

_________________
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more.
http://keasigmadelta.co.nz/ - more of my software.
   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2006/11/30 11:30
From Finland
Posts: 1281
Quote:

Is there any other developer who wants to take a shot at updating adtools?


There's a binutils 2.19.1 in "branches/binutils/". I don't know how well it works though (the latest commit message is "Now compiles again").

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2008/10/29 10:20
From Uppsala, Sweden
Posts: 632
@alfkil
Any new updates on its way?
I asked you before but dont remember if it possible to port
qBittorrent later.

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2009/10/7 0:11
Posts: 986
@joeled

I don't think I will port qBittorrent, because it depends on the boost asio library, which will be somewhat difficult to port because of missing features in our tcp stack. I can, however, probably use some of the concepts from libtorrent-rasterbar to implement udp support in the torrent demo. I have a lot to do at the moment though, so it is going to wait a few weeks.

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2008/10/29 10:20
From Uppsala, Sweden
Posts: 632
@alfkil

Whats the pros and cons with the torrent demo program?

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2008/10/29 10:20
From Uppsala, Sweden
Posts: 632
Anyone with a sam460 managed to get Vacuum to work with text in the chat window? When i type something it doesnt show up in the window and neither does the reply from the other person. Any configuration i missed?

   Report Go to top

Re: Beta testing
Just popping in
Joined:
2006/12/5 22:11
From Lecco, Italy
Posts: 246
I am making some test with the beta 2, so far my findings:
1) the tooltip problem it's still present, I want remember that if you move
slowly the mouse so une tooltip close before the new one opens it's ok,
if you move the mouse fast and the new one it's bigger than the old one
the new one it's only partially displayed.
2) juffed at start display the massage: "QtLockedFile::lock(): fcntl: Function not implemented"
then a DSI recoverable error (but not every time), triyng to save a file
opening the "File" menu going down towards "Save as" when I pass
over Recent files I get "Couldn't open popup window!" message and
juffed stop working with the "File" menu opened. All without native menus
scout says juffed is waiting semaphore

more to come

   Report Go to top

Re: Beta testing
Just popping in
Joined:
2006/12/5 22:11
From Lecco, Italy
Posts: 246
More on juffed
the problem with the "recent files" doesn't appear with the native menus
or if there are some files in the "recent menu" I also have ISI error exiting
juffed, let me know if I may post the stack trace or others information
about DSI and ISI
A little update on the "Recent files" problem, when blocked after few minutes
the program unlock and continue to work

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2008/10/29 10:20
From Uppsala, Sweden
Posts: 632
@pvanni
Have you tired Vacuum? Do you get any text in the chat windinow?

   Report Go to top

Re: Beta testing
Just popping in
Joined:
2006/12/5 22:11
From Lecco, Italy
Posts: 246
Unfortunately I don't know how to do with it, I don't use IM
programs, the program after asking for "Work:" assign start
but after this I don't know how to do

   Report Go to top

Re: Beta testing
Not too shy to talk
Joined:
2007/1/6 5:59
Posts: 250
I would be interested to download package, I have some spare time now :)

So where do I get it?

   Report Go to top

Re: Beta testing
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 2745
Ok Alfkil, here the entire test of QT 4.7.0 (0.9.0 Beta 2), as usual all demos was tested on a Sam440 Flex 800 + Radeon 9250 + AmigaOS 4.1 Update 6 (with all latest updates installed)

This time the installation procedure goes well, however as you suggest at the end of the installation i was forced to add this line on User-Startup

assign sobjs: SYS:sobjs

(Maybe next time this can be done automatically by the installer ?)

My current prefs configuration for QT are:

Native Menus (ON)
Native Dialogs (ON)
Native Paint engine (ON)
Native Fonts (OFF)

In all examples/demos i changed the tooltype in order to run them from Workbench instead of Shell, also for all of them i set this stack: 2000000

So let's start the test !

BIN
----------

qtdemo --> OK
assistant --> OK (slow)
designer --> NO (DSI crash)
linguist --> NO (DSI crash)


DEMOS
----------

affline --> OK
arthurplugin --> ? (no binary ?)
books --> OK
boxes --> NO (ERROR, OpenGL version 1.5 or higher is required to run this demo)
browser --> OK (some crashes here and there, font issue)
chip --> OK
declarative/minehunts --> OK (a bit slow)
deform --> OK (Couldn't open font times new roman,utopia.font)
embeddeddialogs --> OK (DSI crash at startup)
gradients --> OK
interview --> OK
mainwindow --> OK
pathstroke --> OK
spreadsheet --> OK
sqlbrowser --> OK
sub-attaq --> OK
textedit --> OK
undo --> OK

EXAMPLES
----------

animation/animatedtiles --> OK
animation/appchoser --> OK
animation/easing --> OK
animation/moveblock --> OK
animation/states --> OK (DSI crash at startup)
animation/stickman --> OK

designer/calculatorbuilder --> OK
designer/calculatorform --> OK
designer/worldtimeclockbuilder --> OK

desktop/systray --> OK
desktop/screenshot --> OK

dialogs/classwizard --> OK
dialogs/configdialog --> OK
dialogs/extension --> OK
dialogs/findfiles --> OK
dialogs/licencewizard --> OK
dialogs/standarddialogs --> OK
dialogs/tabdialog --> OK
dialogs/trivialwizard --> OK

draganddrop/delayedencoding --> OK (can't drag the icon?)
draganddrop/draggableicons --> OK
draganddrop/draggabletext --> OK
draganddrop/dropsite --> OK
draganddrop/fridgemagnets --> OK
draganddrop/puzzle --> OK

effects/blurpicker --> OK
effects/fademessage --> OK
effects/lighting --> OK

gestures/imagegestures --> OK

graphicsview/anchorlayout --> OK
graphicsview/basicgraphicslayouts --> OK
graphicsview/collidingmice --> OK (black glitches in scrollbar if you resize the window)
graphicsview/diagramscene --> OK
graphicsview/dragdroprobot --> OK
graphicsview/elasticnodes --> OK
graphicsview/padnavigator --> OK (DSI crash at startup)
graphicsview/portedasteroids --> OK (No audio yet)
graphicsview/portedcanvas --> OK
graphicsview/simpleanchorlayout --> OK
graphicsview/weatheranchorlayout --> OK (QPainter::setCompositionMode: PorterDuff modes not supported on device)

help/contextsensitivehelp --> OK
help/remotecontrol --> OK
help/simpletextviewer --> OK (unreadable fonts)

ipc/localfortuneclient --> OK
ipc/localfortuneserver --> OK
ipc/sharedmemory --> OK (DSI crash when clicking on "Load image from file...")

itemviews/addressbook --> OK
itemviews/basicsortfiltermodel --> OK
itemviews/chart --> OK
itemviews/coloreditorfactory --> OK
itemviews/combowidgetmapper --> OK
itemviews/customsortfiltermodel --> OK
itemviews/delayedencoding --> ? (no binary ?)
itemviews/dirview --> OK
itemviews/editabletreemodel --> OK
itemviews/fetchmore --> OK
itemviews/frozencolumn --> OK
itemviews/pixelator --> OK
itemviews/puzzle --> OK
itemviews/simpledommodel --> OK
itemviews/simpletreemodel --> OK
itemviews/simplewidgetmapper --> OK
itemviews/spinboxdelegate --> OK
itemviews/stardelegate --> OK

layouts/basiclayouts --> OK
layouts/borderlayout --> OK
layouts/dynamiclayouts --> OK
layouts/flowlayout --> OK

linguist/arrowpad --> OK
linguist/hellotr --> OK
linguist/trollprint --> OK

mainwindows/application --> OK
mainwindows/dockwidgets --> OK
mainwindows/mdi --> OK
mainwindows/menus --> OK
mainwindows/recentfiles --> OK
mainwindows/sdi --> OK

network/blockingfortuneclient --> OK
network/broadcastreceiver --> OK
network/broadcastsender --> OK
network/download --> NO (DSI crash)
network/downloadmanager --> NO (DSI crash)
network/fortuneclient --> OK
network/fortuneserver --> OK
network/googlesuggest --> OK
network/http --> OK
network/loopback --> OK
network/network-chat --> OK
network/qftp --> OK
network/securesocketclient --> OK
network/threadedfortuneserver --> OK
network/torrent --> OK (UDP support missing)

opengl/2dpainting --> OK (slow)
opengl/framebufferobject --> NO (This system does not support OpenGL/framebuffer objects.)
opengl/framebufferobject2 --> NO (This system does not support OpenGL/framebuffer objects.)
opengl/grabber --> OK (DSI crash when exit)
opengl/hellogl --> OK
opengl/overpainting --> OK (a bit slow and graphics corruption)
opengl/samplebuffers --> NO (freeze, a bit slow and graphics corruption)
opengl/textures --> OK (DSI crash when exit)

painting/basicdrawing --> OK
painting/concentriccircles --> OK
painting/fontsampler --> OK
painting/imagecomposition --> OK
painting/painterpaths --> OK
painting/svggenerator --> OK
painting/svgviewer--> OK (a bit slow)
painting/transformations --> OK

qtconcurrent/imagescaling --> OK
qtconcurrent/mapdemo --> NO (does not start)
qtconcurrent/progressdialog --> OK
qtconcurrent/runfunction --> NO (does not start)
qtconcurrent/wordcount --> NO (does not start)

qtestlib/tutorial1 --> OK
qtestlib/tutorial2 --> OK
qtestlib/tutorial3 --> OK
qtestlib/tutorial4 --> OK
qtestlib/tutorial5 --> OK

richtest/calendar --> OK
richtest/orderform --> OK
richtest/syntaxhighlighter --> OK
richtest/textobject --> OK

sql/cachedtable --> OK
sql/drilldown --> OK
sql/masterdetail --> OK
sql/querymodel --> OK
sql/relationaltablemodel --> OK
sql/sqlwidgetmapper --> OK
sql/tablemodel --> OK

statemachine/eventtransitions --> OK
statemachine/factorial --> OK
statemachine/pingpong --> OK
statemachine/rogue --> OK (Couldn't open font Monospace.font)
statemachine/trafficlight --> OK
statemachine/twowaybutton --> OK

thread/mandelbrot --> OK
thread/semaphores --> OK
thread/waitconditions --> OK

tools/codecs --> OK
tools/completer --> OK
tools/contiguouscache --> OK
tools/customcompleter --> OK
tools/echoplugin --> NO (ISI crash)
tools/i18n --> OK
tools/inputpanel --> OK
tools/plugandpaint --> OK
tools/plugandpaintplugins --> ? (no binary included ?)
tools/regexp --> OK
tools/settingseditor --> OK
tools/styleplugin --> OK
tools/treemodelcompleter --> OK
tools/undoframework --> OK

touch/dials --> OK
touch/fingerpaint --> OK
touch/knobs --> OK
touch/pinchzoom --> OK

tutorials/addressbook/part1 --> OK
tutorials/addressbook/part2 --> OK (graphical glitch at opening, the window will be rescaled automatically)
tutorials/addressbook/part3 --> OK (graphical glitch at opening, the window will be rescaled automatically)
tutorials/addressbook/part4 --> OK
tutorials/addressbook/part5 --> OK
tutorials/addressbook/part6 --> OK
tutorials/addressbook/part7 --> OK

uitools/multipleinheritance --> OK
uitools/textfinder --> OK

webkit/domtraversal --> OK (Couldn't open font arial.font)
webkit/fancybrowser --> OK (Couldn't open font arial.font)
webkit/formextractor --> OK (Couldn't open font arial.font)
webkit/framecapture --> OK
webkit/previewer --> OK (Couldn't open font arial.font)
webkit/simpleselector --> OK (Couldn't open font Lucida Grande.font)

widgets/analogclock --> OK
widgets/calculator --> OK (can't resize the window)
widgets/calendarwidget --> OK
widgets/charactermap --> OK
widgets/codeeditor --> OK
widgets/digitalclock --> OK
widgets/groupbox --> OK
widgets/icons --> OK
widgets/imageviewer --> OK
widgets/lineedits --> OK
widgets/movie --> OK
widgets/scribble --> OK
widgets/shapedclock --> OK (a bit slow)
widgets/sliders --> OK
widgets/spinboxes --> OK
widgets/styles --> OK
widgets/stylesheet --> OK
widgets/tablet --> OK
widgets/tetrix --> OK (shortcuts does not work)
widgets/tooltips --> OK
widgets/validators --> OK
widgets/wiggly --> OK
widgets/windowflags --> OK (graphical glitch at opening, the window will be rescaled automatically)

xml/dombookmarks --> OK
xml/htmlinfo --> OK
xml/rsslisting --> NO (The usage of QHttp is not recommended anymore, please use QNetworkAccessManager)
xml/saxbookmarks --> OK
xml/streambookmarks --> OK
xml/xmlstreamlint --> OK

xmlpatterns/filetree --> OK
xmlpatterns/qobjectxmlmodel --> NO (QMetaProperty::read: Unable to handle unregistered datatype 'SelectionBehavior' for property 'QTabBar::selectionBehaviorOnRemove')
xmlpatterns/recipes --> OK
xmlpatterns/schema --> OK
xmlpatterns/trafficinfo --> NO (freeze at startup)
xmlpatterns/xquery --> ? (no binary ?)
-------------------------------

I send you via mail all specific crashes so eventually you can check them easily

   Report Go to top

Re: Beta testing
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
@samo79

Quote:
This time the installation procedure goes well, however as you suggest at the end of the installation i was forced to add this line on User-Startup

assign sobjs: SYS:sobjs

(Maybe next time this can be done automatically by the installer ?)


I'd be seriously worried if you needed to do that - it's a standard AmigaOS assign that is created before startup-sequence even runs (same as C:, LIBS: etc). Check through very carefully that you haven't re-assigned SObjs: somewhere else during the cause of user-startup and other startup scripts.

   Report Go to top

Re: Beta testing
Just popping in
Joined:
2007/10/5 13:20
Posts: 107
Since QT is now available for AmigaOS how hard would it be to port a QT app like the following one to Amiga?

http://www.scribus.net/canvas/Scribus

_________________
DiscreetFX Team
http://www.discreetfx.com
Making Your Digital Films More Effective!
   Report Go to top

Re: Beta testing
Not too shy to talk
Joined:
2007/1/6 5:59
Posts: 250
Is this problem mentioned here already?

Mouse pointer is targeted wrongly, it is like ghost pointer wich is couple centimeters upper than real mouse pointer.

I've usb mouse and sam 440ep flex with all OS updates.

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2009/6/1 13:11
From Germany
Posts: 619
Scribus is very welcome :)
It looks good

_________________
AmigaOne X1000 Betatester A1-X1090
AmigaOne X1000/4GB Ram/Saphire Radeon 7850 1GB/256GB SSD HD/2GB CF Card/RTL8169Network/
http://www.a1k.org/forum/showthread.php?t=28870
   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2009/10/7 0:11
Posts: 986
@Chris

About assign: SObjs: is NOT assigned before for some reason. Apparently it uses some kind of "lazy" method, so it only gets assigned when someone opens a shared object (at least that's what I think). I tried removing this line from the installer, with grim results. Of course I could just move all Qt libs to sys:, but they are rather large, and I like keeping Qt in one place. If you disaggree, it is very easy for you to copy all the files from qt:lib to your sys partition and delete the mentioned line from your startup-sequence. :)

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2009/3/10 10:51
From Germany
Posts: 579
@alfkil

I *assume* the system assign "SOBJS:" is done by some semi-secret internal Exec or DOS mechanism on boot up.

- It is definately *not* done in the "startup-sequence"!
- This assign seems to be set up as an "assign SOBJS: DEFER", which means it is "activated" upon first use.
- You can *not* "assign ... ADD" an additional path to an DEFERred assigns, like you would like to do! (You can try this yourself manually in a shell!).
- You might circumvent this behaviour (is it as designed or a bug?) by doing for example a simple "CD SOBJS:". Afterwards it is a "normal" assign and you can add additional pathes to it.

_________________
X1000|II/G4|440ep|2000/060|2000/040|1000
   Report Go to top


« 1 2 3 (4) 5 6 7 ... 40 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2014 The XOOPS Project