Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
8 user(s) are online (4 user(s) are browsing Forums)

Members: 0
Guests: 8

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 ... 35 36 37 (38) 39 40 »


Re: Beta testing
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
@ChrisH

Quote:
I've done it in PortablE (until I switch to generating plain C code)


You're switching to generating plain C code? Excellent! That should make executables a bit smaller. Not that I've touched PortablE for ages, mind.

   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1186
@alfkil
You must be right, I have to check the filenames who are passed to the QThread.

Thanks

   Report Go to top

Re: Beta testing
Site Builder
Joined:
2006/12/2 23:57
From Athens
Posts: 347
May I ask guys which is the latest version of the QT Quick Fixes and where can I get it?

   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1186

   Report Go to top

Re: Beta testing
Site Builder
Joined:
2006/12/2 23:57
From Athens
Posts: 347
@zzd10h
Thanks for the link and reply.

   Report Go to top

Re: Beta testing
Not too shy to talk
Joined:
2013/10/5 14:07
From Italy
Posts: 496
@zzd10h
Guillaume i fixed the problems with smtube on Aone.
How ? simple i just put the 2Gb of Kingstone Sodim and the machine is running like a F1 car!
smTube 480p play only 25-35% cpu usage.. new optimized version of Mplayer is needed for 720p!

   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1186
@tlosm

Yes it uses memory ;)

   Report Go to top

Re: Beta testing
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
I've uploaded a new version of qpdfview (there were spiders making their home in the old one). I might have inadvertently broken something that worked previously, as I haven't tested it much.

With the tiled renderer it seems a bit quicker than the old one. Might be my imagination though.

   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1186
@Chris

Yes, for me too it seems faster...

But now, at close of pdfview (tested with many differents PDF, I have a debug message in a console

"QSqlDatabasePrivate::removeDatabase: connection 'qt_sql_default_connection' is still in use, all queries will cease to work."

I never seen it with the previous release.

The same for you ?

   Report Go to top

Re: Beta testing
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
@zzd10h

Oh yeah, I forgot about that error between testing and uploading it last night, and posting about it today.

I remember it happened on the previous version too, but I got rid of it... I thought by stopping it using SQL, but I did that this time and the error still showed up.

Oh, this is the bug: https://bugs.launchpad.net/qpdfview/+bug/1239126

Building without SQL should work, but appears to not have done. There's a fix in that bug report too, although my comments there suggest it doesn't fix it.

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2006/11/24 18:52
From Gloucestershire, UK.
Posts: 859
@Chris

Posting here instead of os4depot comments.

I get no images in the gadgets here. the console spits out:

QImage::scaled: Image is a null image
QImage::scaled: Image is a null image
Failed to create icon image!

33 times.

I have no problem with missing gadgets with any other QT apps.

Where are the image files located?

_________________
Amiga user since 1985
AOS4, Alinea, (can't say), (another I can't say), (and another) Betatester

Ps. I hate the new amigans website <shudder>
Pps. and it's getting worse <double shudder>
   Report Go to top

Re: Beta testing
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
@Severin

I'm fairly sure they're compiled into the executable - certainly my working qpdfview install doesn't have them as separate files.

They are in SVG format, so make sure qt:plugins/imageformats/libqsvg.so exists. What else do you have in that directory?

edit Try adding SVG to ENVARC:QT_DT_BLACKLIST

   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1186
@Chris

Do you have the previous 4.6 version available ?

I replaced the working 4.6 with the new one without make a backup

Thank you


   Report Go to top

Re: Beta testing
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
@zzd10h

I have a copy here. I'd rather fix the new one though, what's wrong?

   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1186
@Chris
Nothing really wrong except the console message at exit.

But if you will fix it, I will wait for new version

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2006/11/24 18:52
From Gloucestershire, UK.
Posts: 859
@Chris

Seems the plugins drawer went AWOL along with include, probabaly a few months ago when I had an error on the drive and did a copy, format, replace.

Thanks for the pointer.

_________________
Amiga user since 1985
AOS4, Alinea, (can't say), (another I can't say), (and another) Betatester

Ps. I hate the new amigans website <shudder>
Pps. and it's getting worse <double shudder>
   Report Go to top

Re: Beta testing
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
@zzd10h

I've fixed it. I'll wait for others to find new problems.

Patch here: http://www.unsatisfactorysoftware.co. ... /amiga/qpdfview_patch.lha

I'll re-upload the full thing if there are no more reports... the patch archive is a lot smaller though.


Edited by Chris on 2014/8/11 22:27:28
   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1186
@Chris

Patched qpdfview works well, no more exit messages.

thank you.

   Report Go to top

Re: Beta testing
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 2745
@Chris

Ok patch solved the issue on exit, however still other two issues:

- Content menu for opening the attached documentation doesn't work, it opens a DOS requester instead, ok i already told you about this and it's not so important either, but considering that it doesn't work, how about removing it ?

- The "Open folder" option in context menu should opened a folder that contain the PDF you are currently showing, but it doesn't !
If you click on it an appdir command wil be called and here it open my web browser instead, this should be fixed

Aniway it's a pretty fast reader !

   Report Go to top

Re: Beta testing
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 2862
@samo79

Quote:
- Content menu for opening the attached documentation doesn't work, it opens a DOS requester instead, ok i already told you about this and it's not so important either, but considering that it doesn't work, how about removing it ?


I have no interest in fixing this. Remove it... maybe, but that's the sort of thing I'd need to patch in every time I do a release so I'd rather not.

Quote:

- The "Open folder" option in context menu should opened a folder that contain the PDF you are currently showing, but it doesn't !
If you click on it an appdir command wil be called and here it open my web browser instead, this should be fixed


That's a Qt bug. It's the thing I keep whinging about that URLs always open in OWB, whereas they should be sent to launch-handler. When Alfkil fixes this (anybody heard from him recently?), WBOpenURL will allow file:// links to open in WB.

   Report Go to top


« 1 ... 35 36 37 (38) 39 40 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2014 The XOOPS Project