Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
9 user(s) are online (6 user(s) are browsing Forums)

Members: 0
Guests: 9

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 2 3 4 (5) 6 7 8 ... 40 »


Re: Beta testing
Quite a regular
Joined:
2009/5/1 17:57
From Czech Republic
Posts: 831
Quote:

DiscreetFX wrote:
Since QT is now available for AmigaOS how hard would it be to port a QT app like the following one to Amiga?

http://www.scribus.net/canvas/Scribus

I wouldn't hold out much hope for Scribus. People often think that open-source apps will be lean and fast and easy to port but this is absolutely not the case with Scribus. On the contrary: it's a rather complex and bloated piece of software.

_________________
- Do you suffer from long-term memory loss?
- I can't remember.
   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1414
YES!!! My Peg2 is happy with my network again, AKA it works!
I'll report here if i find something that you guys haven't found!

// a happy spot trying to catch up!

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2009/10/7 0:11
Posts: 986
@cha05e90

CD SObjs:? That is brilliant! Thank you :)

   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1414
The installer doesn't add an assign to the lib/ dir?
The so files wasn't found on my computer.

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2009/10/7 0:11
Posts: 986
Update 3 is ready. I have sent a link by email. Anyone not on the list who wants to join in, send me a PM with your email addr.

@spotUP
Yes, I removed the assign sobjs: sys:sobjs line, because it didn't make a difference here. But apparently it does elsewhere. I have tried instead to add a "run cd sobjs:" instead, hope it works. Check out the new version.

@samo79

My comments to the relevant (non-working) parts:

BIN
----------

>>qtdemo --> OK

Cool, no? ;)

>>assistant --> OK (slow)

Yes, but still a good alternative to webbrowsing to qt-project.org

>>designer --> NO (DSI crash)
Fixed

>>linguist --> NO (DSI crash)
Fixed

DEMOS
----------

>>arthurplugin --> ? (no binary ?)
It's a plugin ;) Look in qt:plugins/designer to find it.

>>browser --> OK (some crashes here and there, font issue)
I know there are certain issues, like huge slowdown on javascript heavy pages. I'm not going to do too much work here, because I don't think this browser is going to be everyday use for people out there. Rather it is a proof of concept, and the webkit engine is useful for porting other apps.

>>deform --> OK (Couldn't open font times new roman,utopia.font)
Copy/paste them from your favorite Winboevs machine ;)

>>embeddeddialogs --> OK (DSI crash at startup)
Check out this one in the new beta update 3 ;)


EXAMPLES
----------

>>animation/states --> OK (DSI crash at startup)
This one has improved also in the next update

>>draganddrop/delayedencoding --> OK (can't drag the icon?)
I think the deal is, that you have to drag files onto the image area, and outside drag events are not supported in the current Qt port.

>>graphicsview/collidingmice --> OK (black glitches in scrollbar if you resize the window)
Fixed, maybe?

>>graphicsview/padnavigator --> OK (DSI crash at startup)
Fixed, and graphics improved

>>graphicsview/portedasteroids --> OK (No audio yet)
Audio is from default not implemented in this example. There's no code for it.

>>help/simpletextviewer --> OK (unreadable fonts)
Fixed?

ipc/sharedmemory --> OK (DSI crash when clicking on "Load image from file...")
Fixed?

network/download --> NO (DSI crash)
Fixed

network/downloadmanager --> NO (DSI crash)
Fixed

>>opengl/2dpainting --> OK (slow)
Because of gradients, I think. Not much to do about it...

>>opengl/grabber --> OK (DSI crash when exit)
Strange... I am on my X1000, so opengl issues will have to wait

>>qtconcurrent/mapdemo --> NO (does not start)
>>qtconcurrent/runfunction --> NO (does not start)
>>qtconcurrent/wordcount --> NO (does not start)
They work, but there are no guis (look in the code). If you have a serial terminal, you should see some output.

>>tools/echoplugin --> NO (ISI crash)
Try from shell

>> widgets/calculator --> OK (can't resize the window)
That's part of the code. The fixed size is set after the window has opened, andf there is no way to hide the size gadget of an already opened window.

>>widgets/shapedclock --> OK (a bit slow)
Now?

>>widgets/tetrix --> OK (shortcuts does not work)
I think this is because the tetrix widget has strong focus, and thus key events don't get to the main widget

>>xml/rsslisting --> NO (The usage of QHttp is not recommended anymore, please use QNetworkAccessManager)
I think the url used has expired

>>xmlpatterns/trafficinfo --> NO (freeze at startup)
Fixed. Not very useful, because the online service used has expired. But at least it doesn't crash anymore.

>>xmlpatterns/qobjectxmlmodel --> NO (QMetaProperty::read: Unable to handle unregistered datatype 'SelectionBehavior' for property 'QTabBar::selectionBehaviorOnRemove')
I'm tired and hungry...

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2009/6/1 13:11
From Germany
Posts: 619
@alfkil
Downloading and decrunching works.
Installation works.
It is not recommendable to make an update installation.
I tried it and nothing works then
Delete all QT stuff and install it new.
Here and there are some bugs but i will send it over e-mail

_________________
AmigaOne X1000 Betatester A1-X1090
AmigaOne X1000/4GB Ram/Saphire Radeon 7850 1GB/256GB SSD HD/2GB CF Card/RTL8169Network/
http://www.a1k.org/forum/showthread.php?t=28870
   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2009/10/7 0:11
Posts: 986
@tommysammy

Also I forgot to add the new icons. Sorry, will do for the real release.

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2009/6/1 13:11
From Germany
Posts: 619
No problem alfkil from time to time i will create more icons.
First we must eliminate all the bugs. That is more important

_________________
AmigaOne X1000 Betatester A1-X1090
AmigaOne X1000/4GB Ram/Saphire Radeon 7850 1GB/256GB SSD HD/2GB CF Card/RTL8169Network/
http://www.a1k.org/forum/showthread.php?t=28870
   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1414
Allright, some serious testing done here.
I totally wiped my system partition, and reinstalled update 6 + applied all betaupdates. So my system is completely clean.

I then installed Qt the first thing i did.

When I try yo start any qt app I get a requester:

Failed to load shared object libQtGui.so

If i do (which shouldn't be needed imo);
assign sobjs: Beta:SObjs/
I still get the same problem.

After that i tried the following:
assign sobjs: Qt:lib/ add

And started Animated Tiles. I got a crash.

Remember, this is on a virgin os4 install.
Maybe i need to raise the stack.

I am just trying to do this properly, as a new os4 user. ;)

Right, so now i did:

stack 50000000

in shell and started the same file, and voila, it works.

Stack cookies could perhaps be added to all qt apps?

   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1414
Right, going through some of the ones that was reported as fixed in the latest beta:

qtdemo:
the quit button is offsetted, to highlight it i have to hold the mouse appr. 1 cm under the button.
Update: Installing Arial fixes the offset and the garbled font. All OK now.

assistant:
the text in the menus looks garbled. File looks like Fle and the rest are more garbled.
Update: Installing Arial fixes the offset and the garbled font. All OK now.


Edited by spotUP on 2013/5/26 16:27:59
Edited by spotUP on 2013/5/26 16:29:02
   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1414
designer:
seems to work fine but the mouse is offsetted here as well.

linguist:
whem i raised the stack to 1000000 it works, but it has the same problems as the others with strange looking menu texts, i may need to install arial or whatever?
Update: Installing Arial fixes the offset and the garbled font. All OK now.

vacuum:
asks for a work: assign.

browser:
looked totally broken without arial, works fine now! (apart from the images not loading on qt.nokia.com).

deform:
crashes. i don't have the utopia font installed though.


Edited by spotUP on 2013/5/26 16:18:40
Edited by spotUP on 2013/5/26 16:30:53
Edited by spotUP on 2013/5/26 16:39:38
   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1414
embededdialogues:
can't get it to work here. (stack is 10000000).

animation/states:
crashes.

graphicsview/collidingmice
works when resizing now. =)

   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1414
>>graphicsview/padnavigator :
the font looks a bit weird. the text doesn't fit in what looks like invisible boxes.
it freezes when i hit enter.


help/simpletextviewer --> OK (unreadable fonts)
The fonts looks very readable to me now.
However if i mark "Simple Text Viewer" and scroll up and down there is a glitch in the mark color.

ipc/sharedmemory --> OK (DSI crash when clicking on "Load image from file...")
Crash on start here.


network/download --> NO (DSI crash)
Works here now.


network/downloadmanager --> NO (DSI crash)
Works here now.

tools/echoplugin
When started from shell i get a requester saying: error can't load plugin.
After that an uresponsive dialogue window pops up.

>>widgets/shapedclock --> OK (a bit slow)
Doesn't seem slow. If i click RMB several times many menus appear and some draws a bit wrong, and if i click it when i have several of those showing i get a crash.


   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1414
Allright, that's all of them. If you need crashlogs or something just let me know and i'll give you more details.

   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1414
Testing some of the ported apps now...

Easypaint - very fast, like totally useable! No obvious problems! =)
Pencil - seems to have some problems when using the brush tool. Some of the paint gets lost.
Flasq: i first clicked insert new symbol.. and fiddled around some.. then i clicked new in the library and got this:


Qt has caught an exception thrown from an event handler. Throwing
exceptions from an event handler is not supported in Qt. You must
reimplement QApplication::notify() and catch all exceptions there.

terminate called after throwing an instance of 'std::bad_alloc'
what(): std::bad_alloc

BTW, is this a full fledged flash animation editor? O_o

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2009/10/7 0:11
Posts: 986
@spotUP

Hey man, thanks for the heavy testing :). It looks like I have a few problems to fix still... I will use your report as reference.

Quick question: What are your settings in Prefs/Qt? I think I sent an email recommending the following setup:

Native fonts: OFF
Native menus: OFF
Native dialogs: OFF
Native painting: ON

About fonts: I have arial installed, and thus have not experienced the problems with browser etc. Would it be uncool/illegal of me to include it in the release? If no, how does one install it from a script? I don't have Urial font installed, so I am surprised, that you experience problems with that one. Again: Are you using native fonts? If yes, please turn them off. I am seriously considering dumping them from the prefs entirely, too many problems...

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2009/10/7 0:11
Posts: 986
NOTE TO ALL: Please use qtdemo to launch all the examples, that way there is no confusion about stack size!

   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1414
alfkil i use the settings you recommended. this was not the default when installed though, so maybe you should make it default.
i know some browser used to have a script to download and install the fonts. was it firefox or owb?

   Report Go to top

Re: Beta testing
Quite a regular
Joined:
2009/10/7 0:11
Posts: 986
@spotUP
Quote:
Testing some of the ported apps now...


I didn't do too much work on the ports before uploading the latest version. I should probably have done that...

Quote:
Easypaint - very fast, like totally useable! No obvious problems! =)

...and I didn't change a single line in the source ;)

Quote:
Pencil - seems to have some problems when using the brush tool. Some of the paint gets lost.

Can't reproduce. Maybe some Composite problem?

Quote:

Flasq: i first clicked insert new symbol.. and fiddled around some.. then i clicked new in the library and got this:

Oops! Well, you need to first create a new document from the files menu, then you should be able to create symbols from the library tab. Note, this is not a fully functional app, it is merely an adaptation of a very bad program called "Flash4Linux", which was basically just a framework with a lot of empty menus (most menu items don't work as a result) and a few bad drawing functions. I have improved it *a lot* (which says very little), and, well, you should be able to create a simple swf file (export), that you can view with gnash. No actionscript, and not a lot of drawing functionality, but hey, it's howgrown ;)

Has anyone tried MuseScore at all??

   Report Go to top

Re: Beta testing
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1414
yes, mui-owb has the script that downloads and installs fonts...

here it is:


; OWB Font Downloader

failat 21

echo "Welcome to OWB Font Downloader!"

cd datas

requestchoice >env:OWBch "OWB Font Downloader" "Do you want to download and install fonts? Approx 4 MB of font*Narchives will be downloaded.*N*NInstalling fonts will result in coping new font files to SYS:Fonts/_ttf" "Yes" "No"
if val "$OWBch" eq "1"
unsetenv OWBch

if not exists c:xadUnFile
requestchoice >nil: "OWB Font Downloader" "Couldn't locate xadUnFile command." "Ok"
quit 5
else
echo "Deleting old fonts..."
delete #?.exe
delete fonts/#?

wget --tries 10 --waitretry 10 http://kent.dl.sourceforge.net/sourceforge/corefonts/andale32.exe
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't download 'andale32' TrueType font file." "Ok"
quit 5
endif

wget --tries 10 --waitretry 10 http://kent.dl.sourceforge.net/sourceforge/corefonts/arial32.exe
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't download 'arial32' TrueType font file." "Ok"
quit 5
endif

wget --tries 10 --waitretry 10 http://kent.dl.sourceforge.net/sourceforge/corefonts/arialb32.exe
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't download 'arialb32' TrueType font file." "Ok"
quit 5
endif

wget --tries 10 --waitretry 10 http://kent.dl.sourceforge.net/sourceforge/corefonts/comic32.exe
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't download 'comic32' TrueType font file." "Ok"
quit 5
endif

wget --tries 10 --waitretry 10 http://kent.dl.sourceforge.net/sourceforge/corefonts/courie32.exe
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't download 'corie32' TrueType font file." "Ok"
quit 5
endif

wget --tries 10 --waitretry 10 http://kent.dl.sourceforge.net/sourceforge/corefonts/georgi32.exe
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't download 'georgi32' TrueType font file." "Ok"
quit 5
endif

wget --tries 10 --waitretry 10 http://kent.dl.sourceforge.net/sourceforge/corefonts/impact32.exe
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't download 'impact32' TrueType font file." "Ok"
quit 5
endif

wget --tries 10 --waitretry 10 http://kent.dl.sourceforge.net/sourceforge/corefonts/times32.exe
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't download 'times32' TrueType font file." "Ok"
quit 5
endif

wget --tries 10 --waitretry 10 http://kent.dl.sourceforge.net/sourceforge/corefonts/trebuc32.exe
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't download 'trebuc32' TrueType font file." "Ok"
quit 5
endif

wget --tries 10 --waitretry 10 http://kent.dl.sourceforge.net/sourceforge/corefonts/verdan32.exe
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't download 'verdan32' TrueType font file." "Ok"
quit 5
endif

wget --tries 10 --waitretry 10 http://kent.dl.sourceforge.net/sourceforge/corefonts/webdin32.exe
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't download 'webdin32' TrueType font file." "Ok"
quit 5
endif

echo "Fetched all fonts. Now unpacking"

c:xadUnFile andale32.exe fonts file=#?.TTF
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't unpack 'andale32' font archive." "Ok"
quit 5
endif

c:xadUnFile arial32.exe fonts file=#?.TTF
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't unpack 'arial32' font archive." "Ok"
quit 5
endif

c:xadUnFile arialb32.exe fonts file=#?.TTF
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't unpack 'arialb32' font archive." "Ok"
quit 5
endif

c:xadUnFile comic32.exe fonts file=#?.TTF
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't unpack 'comic32' font archive." "Ok"
quit 5
endif

c:xadUnFile courie32.exe fonts file=#?.TTF
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't unpack 'courie32' font archive." "Ok"
quit 5
endif

c:xadUnFile georgi32.exe fonts file=#?.TTF
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't unpack 'georgi32' font archive." "Ok"
quit 5
endif

c:xadUnFile impact32.exe fonts file=#?.TTF
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't unpack 'impact32' font archive." "Ok"
quit 5
endif

c:xadUnFile times32.exe fonts file=#?.TTF
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't unpack 'times32' font archive." "Ok"
quit 5
endif

c:xadUnFile trebuc32.exe fonts file=#?.TTF
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't unpack 'trebuc32' font archive." "Ok"
quit 5
endif

c:xadUnFile verdan32.exe fonts file=#?.TTF
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't unpack 'verdan32' font archive." "Ok"
quit 5
endif

c:xadUnFile webdin32.exe fonts file=#?.TTF
set RES "$RC"
if not val "$RES" eq "0"
requestchoice >nil: "OWB Font Downloader" "Couldn't unpack 'webdin32' font archive." "Ok"
quit 5
endif

echo "All fonts successfully unpacked."
echo "Copying in progress..."

copy fonts/ sys:fonts/_ttf ALL

delete #?.exe ALL
delete fonts ALL

endif

echo "Download and installation of all fonts complete."
endif
unsetenv OWBch

   Report Go to top


« 1 2 3 4 (5) 6 7 8 ... 40 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2014 The XOOPS Project